Paper 2021/813 Original: eprint.iacr.org/2021/813 ↗
Intelligent Composed Algorithms
Abstract
Intelligent Composed Algorithms (ICA) have been developed as a mechanism for introducing new cryptographic algorithms into applications and PKIs. Using ICAs, known cryptographic algorithms (Component-Algorithms) can be combined in order to obtain a stronger mix of cryptographic algorithms or primitives. Using ICAs it is also possible to use known Component-Algorithms as mutual alternatives. Furthermore, the combined and alternative use of Component-Algorithms as ICAs shall enable agile use of cryptographic algorithms without having to change standards as X.509 or CMS. An Intelligent Composed Algorithm is a flexible group of cryptographic algorithms together with the corresponding rules for their combination. The rules for the combination of Component-Algorithms are defined as algorithms (Controlling-Algorithms) themselves. In applications, ICAs are used as conventional algorithms, described by an algorithm identifier (an OID) and matching parameters. The chosen Component-Algorithms are defined by parameters of the Controlling-Algorithm. The use of ICAs impose no need to modify higher-order standards for applications and protocols, as X.509, RFC 5280, RFC 6960, RFC 2986, RFC 4210, and RFC 5652.
Metadata
- Available format(s)
PDF
- Category
- Applications
- Publication info
- Preprint.
- History
- 2021-11-16: last updated
- 2021-06-16: published
- Short URL
- https://ia.cr/2021/813
- License
- https://creativecommons.org/licenses/by/4.0/
BibTeX
@misc{cryptoeprint:2021/813,
author = {Frank Byszio and Dr. Klaus-Dieter Wirth and Dr. Kim Nguyen},
title = {Intelligent Composed Algorithms},
howpublished = {Cryptology {ePrint} Archive, Paper 2021/813},
year = {2021},
url = {https://eprint.iacr.org/2021/813}
}